Uploaded image for project: 'Blazegraph (by SYSTAP)'
  1. Blazegraph (by SYSTAP)
  2. BLZG-793

InvocationTargetException on /namespace call

    Details

    • Type: Bug
    • Status: Closed - Won't Fix
    • Resolution: Incomplete
    • Affects Version/s: BIGDATA_RELEASE_1_2_3
    • Fix Version/s: None
    • Component/s: HAJournalServer
    • Labels:
      None

      Description

      The reason of exception appearing is unknown, sometimes it appears in bulk triples uploading process. After some time exception can disappear and cluster continue working normally.

      See attachment for logs from leader node. In that case exception appears at 7:56:21 and disappears at 7:56:46. There we have about 14 requests to /namespace endpoint each 10 seconds from different servers and services to get list of tenants
      - so there's a lot of logs for this short period of time.

        Activity

        bryanthompson bryanthompson added a comment -

        We are awaiting resolution of [1] in order to verify that the problem can be replicated by the customer in the HA mode when the failover behavior is correct. We are close on a resolution of [1].

        Can this problem be replicated against a non-HA mode NanoSparqlServer instance? If not, then the problem is likely an HA failover issue linked to [1].

        Thanks,
        Bryan

        [1] http://sourceforge.net/apps/trac/bigdata/ticket/695 (HAJournalServer reports "follower" but is in SeekConsensus and is not participating in commits.)

        bryanthompson bryanthompson added a comment -

        Customer can not replicate agaist current code base.


          People

          • Assignee:
            bryanthompson bryanthompson
            Reporter:
            sv3k sv3k
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: