Uploaded image for project: 'Blazegraph (by SYSTAP)'
  1. Blazegraph (by SYSTAP)
  2. BLZG-789 BigdataSailRemoteRepositoryConnection should implement interface methods
  3. BLZG-753

Result of BigdataSailRemoteRepositoryConnection.getStatements() and export() do not preserve statement context.

    Details

    • Type: Sub-task
    • Status: Done
    • Priority: Highest
    • Resolution: Done
    • Affects Version/s: BIGDATA_RELEASE_1_2_0
    • Fix Version/s: None
    • Component/s: Bigdata SAIL
    • Labels:
      None

      Description

      In Sesame when you call RepositoryConnection#export it will produce statements with context. For example this method is used in openrdf workbench for poor man backups: https://bitbucket.org/openrdf/sesame/src/0aaebbb43753/core/http/workbench/src/main/java/org/openrdf/workbench/commands/ExportServlet.java?at=master#cl-64

      but bigdata BigdataSailRemoteRepositoryConnection#export don't keep context in the result data.

        Issue Links

          Activity

          beebs Brad Bebee created issue -
          bryanthompson bryanthompson added a comment -

          Can you provide a unit test? That will reduce our time to replicate the problem and demonstrate a fix.
          Thanks,
          Bryan

          bryanthompson bryanthompson made changes -
          Field Original Value New Value
          Assignee mikepersonick [ mikepersonick ] bryanthompson [ bryanthompson ]
          bryanthompson bryanthompson made changes -
          Parent BLZG-789 [ 12235 ]
          Issue Type Bug [ 1 ] Sub-task [ 5 ]
          bryanthompson bryanthompson added a comment - - edited

          I will take a look at this when increasing the test coverage for the BigdataSailRemoteRepositoryConnection. See BLZG-789

          bryanthompson bryanthompson made changes -
          Summary Result of BigdataSailRemoteRepositoryConnection#export do not preserve statement context. Result of BigdataSailRemoteRepositoryConnection#export does not preserve statement context.
          bryanthompson bryanthompson made changes -
          Summary Result of BigdataSailRemoteRepositoryConnection#export does not preserve statement context. Result of BigdataSailRemoteRepositoryConnection.getStatements() and export() do not preserve statement context.
          Priority Highest [ 1 ]
          bryanthompson bryanthompson added a comment -

          The root cause is how RemoteRepository.getStatements() is implemented. The request is translated into a SPARQL CONSTRUCT query. For example, the following query is generated if the caller specifies a single named graph http://www.bigdata.com/

          CONSTRUCT {
          ?s <http://www.w3.org/2000/01/rdf-schema#label> <http://xmlns.com/foaf/0.1/XXX>
          }
          FROM <http://www.bigdata.com/>
          WHERE {
          ?s <http://www.w3.org/2000/01/rdf-schema#label> <http://xmlns.com/foaf/0.1/XXX>
          }
          

          The CONSTRUCT query is constructing triples, not quads. So the graph is not associated with the response.

          bryanthompson bryanthompson added a comment -

          I suspect that we need to turn this into a SELECT query and project out (s,p,o,c).

          bryanthompson bryanthompson made changes -
          Link This issue relates to BLZG-789 [ BLZG-789 ]
          beebs Brad Bebee made changes -
          Workflow Trac Import v2 [ 12589 ] Trac Import v3 [ 13215 ]
          beebs Brad Bebee made changes -
          Workflow Trac Import v3 [ 13215 ] Trac Import v4 [ 14544 ]
          bryanthompson bryanthompson made changes -
          Assignee bryanthompson [ bryanthompson ] igorkim [ igorkim ]
          beebs Brad Bebee made changes -
          Workflow Trac Import v4 [ 14544 ] Trac Import v5 [ 15895 ]
          igorkim igorkim made changes -
          Status Open [ 1 ] Accepted [ 10101 ]
          igorkim igorkim made changes -
          Status Accepted [ 10101 ] In Progress [ 3 ]
          beebs Brad Bebee made changes -
          Workflow Trac Import v5 [ 15895 ] Trac Import v6 [ 18524 ]
          igorkim igorkim made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          beebs Brad Bebee made changes -
          Workflow Trac Import v6 [ 18524 ] Trac Import v7 [ 19987 ]
          beebs Brad Bebee made changes -
          Workflow Trac Import v7 [ 19987 ] Trac Import v8 [ 21675 ]
          bryanthompson bryanthompson made changes -
          Status Resolved [ 5 ] In Review [ 10100 ]
          bryanthompson bryanthompson made changes -
          Resolution Done [ 10000 ]
          Status In Review [ 10100 ] Done [ 10000 ]

            People

            • Assignee:
              igorkim igorkim
              Reporter:
              aakozlov aakozlov
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: