Uploaded image for project: 'Blazegraph (by SYSTAP)'
  1. Blazegraph (by SYSTAP)
  2. BLZG-596

java.net.ConnectException: Connection refused

    Details

    • Type: Bug
    • Status: Closed - Won't Fix
    • Resolution: Cannot Reproduce
    • Affects Version/s: BIGDATA_RELEASE_1_1_0
    • Fix Version/s: None
    • Component/s: Bigdata Federation
    • Labels:
      None

      Description

      This exception was observed on the mini cluster during query. It persisted across the reboot of 192.168.1.17 and the restart of all services. It was eventually cured by turning off all machines overnight and then restarting them (the hypothesis being that there was something overheating on the minis, which are after all pretty light weight devices). It is also possible that the problem was one or more services which were not terminated. All in all, this was a very odd exception. I could find nearly nothing about the underlying stack trace on the Internet. This ticket is just to make a record of the problem in case something like it ever reoccurs.

      ...1f1aa66b-8db9-4bad-b053-18c4235b7f1d,TcpEndpoint[192.168.1.17:52745]]; nested exception is:
              java.net.ConnectException: Connection refused
        
      Caused by: java.net.ConnectException: Connection refused
              at sun.nio.ch.Net.$$YJP$$connect(Native Method)
              at sun.nio.ch.Net.connect(Net.java)
              at sun.nio.ch.SocketChannelImpl.connect(SocketChannelImpl.java:500)
              at sun.nio.ch.SocketAdaptor.connect(SocketAdaptor.java:81)
              at net.jini.jeri.tcp.TcpEndpoint$ConnectionEndpointImpl.connectToSocketAddress(TcpEndpoint.java:678)
              at net.jini.jeri.tcp.TcpEndpoint$ConnectionEndpointImpl.connectToHost(TcpEndpoint.java:608)
              at net.jini.jeri.tcp.TcpEndpoint$ConnectionEndpointImpl.connect(TcpEndpoint.java:543)
      

        Activity

        bryanthompson bryanthompson added a comment -

        Cured as indicated by a shutdown of all nodes. The root cause was never identified. See my comments on the description for some possible causes.


          People

          • Assignee:
            Unassigned
            Reporter:
            bryanthompson bryanthompson
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: