Uploaded image for project: 'Blazegraph (by SYSTAP)'
  1. Blazegraph (by SYSTAP)
  2. BLZG-580

Deletion of address with size greater than slot

    Details

    • Type: Bug
    • Status: Closed - Won't Fix
    • Resolution: Duplicate
    • Affects Version/s: BIGDATA_RELEASE_1_0_4
    • Fix Version/s: None
    • Component/s: RWStore
    • Labels:
      None

      Description

      Caused by: java.lang.RuntimeException: Problem with entry at -290601782214234    at com.bigdata.rwstore.RWStore.freeDeferrals(RWStore.java:3605)
      
          at com.bigdata.rwstore.RWStore.checkDeferredFrees(RWStore.java:2433)    at com.bigdata.journal.RWStrategy.checkDeferredFrees(RWStrategy.java:673)    at com.bigdata.journal.AbstractJournal.commitNow(AbstractJournal.java:2412)
      
          at com.bigdata.journal.AbstractJournal.commit(AbstractJournal.java:2274)    ... 12 moreCaused by: java.lang.IllegalArgumentException: IAE with address: -24626, size: 253804, context: -1    at com.bigdata.rwstore.FixedAllocator.free(FixedAllocator.java:682)
      
          at com.bigdata.rwstore.RWStore.immediateFree(RWStore.java:1785)    at com.bigdata.rwstore.RWStore.immediateFree(RWStore.java:1762)    at com.bigdata.rwstore.RWStore.freeDeferrals(RWStore.java:3521)    at com.bigdata.rwstore.RWStore.freeDeferrals(RWStore.java:3591)
      
          ... 16 moreCaused by: java.lang.IllegalArgumentException: Deletion of address with size greater than slot - 253804 > 64    at com.bigdata.rwstore.StorageStats$Bucket.delete(StorageStats.java:171)    at com.bigdata.rwstore.FixedAllocator.free(FixedAllocator.java:678)
      
      

        Activity


          People

          • Assignee:
            martyncutcher martyncutcher
            Reporter:
            bryanthompson bryanthompson
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: