Details

    • Type: Bug
    • Status: Done
    • Resolution: Done
    • Affects Version/s: BIGDATA_RELEASE_1_0_4
    • Fix Version/s: None
    • Component/s: RWStore

      Description

      When a large number of frees are deferred due to history retention, if this data is stored as a blob allocation an error is generated when trying to release this after releasing the deferred frees.

        Activity

        martyncutcher martyncutcher added a comment -

        Trace from original error report:

        Problem with entry at -290601782214234
        at com.bigdata.rwstore.RWStore.freeDeferrals(RWStore.java:3605)

        at com.bigdata.rwstore.RWStore.checkDeferredFrees(RWStore.java:2433)
        at com.bigdata.journal.RWStrategy.checkDeferredFrees(RWStrategy.java:673)
        at com.bigdata.journal.AbstractJournal.commitNow(AbstractJournal.java:2412)

        at com.bigdata.journal.AbstractJournal.commit(AbstractJournal.java:2274)
        ... 12 more
        Caused by: java.lang.IllegalArgumentException: IAE with address: -24626, size: 253804, context: -1
        at com.bigdata.rwstore.FixedAllocator.free(FixedAllocator.java:682)

        at com.bigdata.rwstore.RWStore.immediateFree(RWStore.java:1785)
        at com.bigdata.rwstore.RWStore.immediateFree(RWStore.java:1762)
        at com.bigdata.rwstore.RWStore.freeDeferrals(RWStore.java:3521)
        at com.bigdata.rwstore.RWStore.freeDeferrals(RWStore.java:3591)

        bryanthompson bryanthompson added a comment -

        Martyn wrote: Fixes problem when a deferredFree block requires a bob allocation. This was not handled when immediately freeing the block after releasing the allocations referenced within it.

        This commit includes a unit test for the problem in addition to the fix.

        This change also reduces the default allocator sizes to a maximum allocator size of 32MB. Larger allocations will be blobs (the default was historically set at approximately 250MB, which is much too large for a single allocation).

        Committed Revision r5886 against 1.0.x and 1.1.x.

        bryanthompson bryanthompson added a comment -

        We have confirmation that this issue appears to be resolved for the reporter.


          People

          • Assignee:
            martyncutcher martyncutcher
            Reporter:
            martyncutcher martyncutcher
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: