Details

    • Type: Bug
    • Status: Done
    • Resolution: Done
    • Affects Version/s: TERMS_REFACTOR_BRANCH
    • Fix Version/s: None
    • Component/s: RWStore

      Description

      An error has been reported when loading chunks of statements into a quad store in a series of native transactions. The stack trace provided is:

      159688 FixedAllocator returning null address, with freeBits: 6912
      AllocBlock, baseAddress: 16777216 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 98631680 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 101777408 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 112263168 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 129040384 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 134283264 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 139526144 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 144769024 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 150011904 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 160497664 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 162594816 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 167837696 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 169934848 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 178323456 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 180420608 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 185663488 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 196149248 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 201392128 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 204537856 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 209780736 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 220594176 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 225837056 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 231079936 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 236322816 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 241565696 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 246808576 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 252051456 bits: -1 -1 -1 -1 -1 -1 -1 -1
      AllocBlock, baseAddress: 257294336 bits: -1 -1 -1 -1 -1 -1 -1 -1
      
      159688 java.lang.IllegalStateException: No physical address found for 0
      java.lang.IllegalStateException: No physical address found for 0
              at com.bigdata.rwstore.RWStore.alloc(RWStore.java:1875) [TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.rwstore.RWStore.alloc(RWStore.java:1980) [TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.journal.RWStrategy.write(RWStrategy.java:214) [TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.journal.RWStrategy.write(RWStrategy.java:179) [TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.journal.AbstractJournal.write(AbstractJournal.java:2664) [TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.btree.AbstractBTree.writeNodeOrLeaf(AbstractBTree.java:3673) [TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.btree.AbstractBTree.writeNodeRecursive(AbstractBTree.java:3485) [TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.btree.BTree.flush(BTree.java:770) [TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.btree.BTree.writeCheckpoint2(BTree.java:910) [TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.btree.BTree.writeCheckpoint(BTree.java:881) [TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.btree.BTree.handleCommit(BTree.java:1210) [TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.journal.Name2Addr.handleCommit(Name2Addr.java:563) [TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.journal.AbstractJournal.notifyCommitters(AbstractJournal.java:1983) [TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.journal.AbstractJournal.commitNow(AbstractJournal.java:2336) [TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.journal.AbstractJournal.commit(AbstractJournal.java:2250) [TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.rdf.store.LocalTripleStore.commit(LocalTripleStore.java:78) [TERMS_REFACTOR_BRANCH/:na]
      	...
      159688 Error commiting Bigdata
      java.lang.RuntimeException: Could not commit index: name=aHR0cDovL29wZW5hbnpvLm9yZy9kYXRhc291cmNlL3N5c3RlbURhdGFzb3VyY2U=.spo.SCOP,
      commitList=[DirtyListener{name=aHR0cDovL29wZW5hbnpvLm9yZy9kYXRhc291cmNlL3N5c3RlbURhdGFzb3VyY2U=.lex.TERMS,checkpointAddr=0},
      DirtyListener{name=aHR0cDovL29wZW5hbnpvLm9yZy9kYXRhc291cmNlL3N5c3RlbURhdGFzb3VyY2U=.spo.CSPO,checkpointAddr=0},
      DirtyListener{name=aHR0cDovL29wZW5hbnpvLm9yZy9kYXRhc291cmNlL3N5c3RlbURhdGFzb3VyY2U=.spo.OCSP,checkpointAddr=0},
      DirtyListener{name=aHR0cDovL29wZW5hbnpvLm9yZy9kYXRhc291cmNlL3N5c3RlbURhdGFzb3VyY2U=.spo.PCSO,checkpointAddr=0},
      DirtyListener{name=aHR0cDovL29wZW5hbnpvLm9yZy9kYXRhc291cmNlL3N5c3RlbURhdGFzb3VyY2U=.spo.POCS,checkpointAddr=0},
      DirtyListener{name=aHR0cDovL29wZW5hbnpvLm9yZy9kYXRhc291cmNlL3N5c3RlbURhdGFzb3VyY2U=.spo.SCOP,needsCheckpoint},
      DirtyListener{name=aHR0cDovL29wZW5hbnpvLm9yZy9kYXRhc291cmNlL3N5c3RlbURhdGFzb3VyY2U=.spo.SOPC,needsCheckpoint},
      DirtyListener{name=aHR0cDovL29wZW5hbnpvLm9yZy9kYXRhc291cmNlL3N5c3RlbURhdGFzb3VyY2U=.spo.SPOC,needsCheckpoint},
      DirtyListener{name=nguuid,needsCheckpoint},
      DirtyListener{name=uuidng,needsCheckpoint}]: lastRootBlock=rootBlock{
      rootBlock=1, challisField=129, version=2, nextOffset=16862041614385,
      localTime=1309042081108 [Saturday, June 25, 2011 6:48:01 PM EDT],
      firstCommitTime=1309041931859 [Saturday, June 25, 2011 6:45:31 PM EDT],
      lastCommitTime=1309042080889 [Saturday, June 25, 2011 6:48:00 PM EDT],
      commitCounter=129, commitRecordAddr={off=NATIVE:-33453,len=422},
      commitRecordIndexAddr={off=NATIVE:-10288,len=220}, quorumToken=0,
      metaBitsAddr=13886593957942, metaStartAddr=4184, storeType=RW,
      uuid=48fbaa73-4905-4f97-9967-f05213861864, offsetBits=42,
      checksum=-739237274, createTime=1309041929861 [Saturday, June 25, 2011 6:45:29 PM EDT], closeTime=0}
              at com.bigdata.journal.AbstractJournal.commit(AbstractJournal.java:2252) ~[TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.rdf.store.LocalTripleStore.commit(LocalTripleStore.java:78) ~[TERMS_REFACTOR_BRANCH/:na]
      	...
      Caused by: java.lang.RuntimeException: Could not commit index: name=aHR0cDovL29wZW5hbnpvLm9yZy9kYXRhc291cmNlL3N5c3RlbURhdGFzb3VyY2U=.spo.SCOP,
      commitList=[DirtyListener{name=aHR0cDovL29wZW5hbnpvLm9yZy9kYXRhc291cmNlL3N5c3RlbURhdGFzb3VyY2U=.lex.TERMS,checkpointAddr=0},
      DirtyListener{name=aHR0cDovL29wZW5hbnpvLm9yZy9kYXRhc291cmNlL3N5c3RlbURhdGFzb3VyY2U=.spo.CSPO,checkpointAddr=0},
      DirtyListener{name=aHR0cDovL29wZW5hbnpvLm9yZy9kYXRhc291cmNlL3N5c3RlbURhdGFzb3VyY2U=.spo.OCSP,checkpointAddr=0},
      DirtyListener{name=aHR0cDovL29wZW5hbnpvLm9yZy9kYXRhc291cmNlL3N5c3RlbURhdGFzb3VyY2U=.spo.PCSO,checkpointAddr=0},
      DirtyListener{name=aHR0cDovL29wZW5hbnpvLm9yZy9kYXRhc291cmNlL3N5c3RlbURhdGFzb3VyY2U=.spo.POCS,checkpointAddr=0},
      DirtyListener{name=aHR0cDovL29wZW5hbnpvLm9yZy9kYXRhc291cmNlL3N5c3RlbURhdGFzb3VyY2U=.spo.SCOP,needsCheckpoint},
      DirtyListener{name=aHR0cDovL29wZW5hbnpvLm9yZy9kYXRhc291cmNlL3N5c3RlbURhdGFzb3VyY2U=.spo.SOPC,needsCheckpoint},
      DirtyListener{name=aHR0cDovL29wZW5hbnpvLm9yZy9kYXRhc291cmNlL3N5c3RlbURhdGFzb3VyY2U=.spo.SPOC,needsCheckpoint},
      DirtyListener{name=nguuid,needsCheckpoint},
      DirtyListener{name=uuidng,needsCheckpoint}]
              at com.bigdata.journal.Name2Addr.handleCommit(Name2Addr.java:571) ~[TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.journal.AbstractJournal.notifyCommitters(AbstractJournal.java:1983) ~[TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.journal.AbstractJournal.commitNow(AbstractJournal.java:2336) ~[TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.journal.AbstractJournal.commit(AbstractJournal.java:2250) ~[TERMS_REFACTOR_BRANCH/:na]
              ... 13 common frames omitted
      Caused by: java.lang.RuntimeException: java.lang.IllegalStateException: No physical address found for 0
              at com.bigdata.rwstore.RWStore.alloc(RWStore.java:1886) ~[TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.rwstore.RWStore.alloc(RWStore.java:1980) ~[TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.journal.RWStrategy.write(RWStrategy.java:214) ~[TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.journal.RWStrategy.write(RWStrategy.java:179) ~[TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.journal.AbstractJournal.write(AbstractJournal.java:2664) ~[TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.btree.AbstractBTree.writeNodeOrLeaf(AbstractBTree.java:3673) ~[TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.btree.AbstractBTree.writeNodeRecursive(AbstractBTree.java:3485) ~[TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.btree.BTree.flush(BTree.java:770) ~[TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.btree.BTree.writeCheckpoint2(BTree.java:910) ~[TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.btree.BTree.writeCheckpoint(BTree.java:881) ~[TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.btree.BTree.handleCommit(BTree.java:1210) ~[TERMS_REFACTOR_BRANCH/:na]
              at com.bigdata.journal.Name2Addr.handleCommit(Name2Addr.java:563) ~[TERMS_REFACTOR_BRANCH/:na]
              ... 16 common frames omitted
      Caused by: java.lang.IllegalStateException: No physical address found for 0
              at com.bigdata.rwstore.RWStore.alloc(RWStore.java:1875)
      ~[TERMS_REFACTOR_BRANCH/:na]
              ... 27 common frames omitted
      

        Activity

        bryanthompson bryanthompson added a comment -

        Martyn wrote: fix for transientbits calculation used in releaseSession

        Committed revision r4803 (QUADS_REFACTOR_BRANCH)
        Committed revision r4804 (TERMS_REFACTOR_BRANCH)


          People

          • Assignee:
            martyncutcher martyncutcher
            Reporter:
            bryanthompson bryanthompson
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: