Uploaded image for project: 'Blazegraph (by SYSTAP)'
  1. Blazegraph (by SYSTAP)
  2. BLZG-430

Deadlock in TestHASendAndReceive3Nodes stress test

    Details

    • Type: Bug
    • Status: Done
    • Resolution: Done
    • Affects Version/s: QUADS_QUERY_BRANCH
    • Fix Version/s: None
    • Component/s: Quorums

      Description

      A deadlock has been observed in

      com.bigdata.ha.pipeline.TestHASendAndReceive3Nodes#testStressDirectBuffers()
      

      This is being tentatively assigned to the quorum logic.

      The test has been disabled for now to get CI online (it registers as a "failed" test).

        Activity

        beebs Brad Bebee created issue -
        bryanthompson bryanthompson added a comment -

        Bug fix for HA3 mock quorum fixture not terminating correctly. The problem was that we had obtained a list of listeners in the MockQuorumFixture outside of the global lock and were failing to notice when a listener was removed and hence would no longer consume an event which has been dispatched to that listener.

        Committed revision 4545.

        Note: We should try to re-enable this test with this fix.

        bryanthompson bryanthompson added a comment -

        I have re-enabled TestHASendAndReceive3Nodes#testStressDirectBuffers() to see if the problem is fixed with r4545.

        Committed revision 4546.

        beebs Brad Bebee made changes -
        Field Original Value New Value
        Workflow Trac Import v2 [ 12266 ] Trac Import v3 [ 13854 ]
        beebs Brad Bebee made changes -
        Workflow Trac Import v3 [ 13854 ] Trac Import v4 [ 15183 ]
        beebs Brad Bebee made changes -
        Workflow Trac Import v4 [ 15183 ] Trac Import v5 [ 16569 ]
        beebs Brad Bebee made changes -
        Labels Issue_patch_20150625
        beebs Brad Bebee made changes -
        Status Closed - Won't Fix [ 6 ] Open [ 1 ]
        beebs Brad Bebee made changes -
        Status Open [ 1 ] Accepted [ 10101 ]
        beebs Brad Bebee made changes -
        Status Accepted [ 10101 ] In Progress [ 3 ]
        beebs Brad Bebee made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        beebs Brad Bebee made changes -
        Status Resolved [ 5 ] In Review [ 10100 ]
        beebs Brad Bebee made changes -
        Resolution Fixed [ 1 ] Done [ 10000 ]
        Status In Review [ 10100 ] Done [ 10000 ]
        beebs Brad Bebee made changes -
        Workflow Trac Import v5 [ 16569 ] Trac Import v6 [ 17809 ]
        beebs Brad Bebee made changes -
        Workflow Trac Import v6 [ 17809 ] Trac Import v7 [ 19206 ]
        beebs Brad Bebee made changes -
        Workflow Trac Import v7 [ 19206 ] Trac Import v8 [ 20827 ]

          People

          • Assignee:
            bryanthompson bryanthompson
            Reporter:
            bryanthompson bryanthompson
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: