Details

      Description

      Create maven2 POMs for bigdata and break various dependency cycles making it possible to create a series of layered artifacts for deployment. Update the release guide [1] to reflect the new release procedures for the maven build artifacts.

      The generated artifacts and together with any dependencies not commonly found in maven2 repositories can be published to a maven repository on http://www.bigdata.com, permitting us to automate some of the more tedious aspects of publishing new maven artifacts.

      TODO The mavenization will change some paths and will effect references into git on our web site. Find all such references and update those broken links.

      [1] https://sourceforge.net/apps/mediawiki/bigdata/index.php?title=ReleaseGuide

        Issue Links

          Activity

          bryanthompson bryanthompson added a comment -

          I have removed the bigdata-gas test suite execution from the main project due to errors when run as part of the CI for that module that do not exist when run by itself using "mvn clean package".

          TODO At this point, the following test suites are no longer being run as part of the main project: bigdata-gas, bigdata-jini. In addition, we have several other modules that need to get into CI as their own maven projects: bigdata-gas, bigdata-jini, bigdata-client, bigdata-ganglia, junit-ext, lgpl-utils, dsi-utils, etc.

          bryanthompson bryanthompson added a comment -

          I have applied fixes for lookup.config and log4j-template-X.properties files that were not being resolved due to the change in the directory path locations. HA CI now runs for me locally under eclipse.

          bryanthompson bryanthompson added a comment -

          Fix for BD GAS imply (test suite resource locations). Commit 183d8b85c6408fd90df0748933a67ff7d7c5cf0f

          bryanthompson bryanthompson added a comment -

          This is a duplicate of BLZG-38.

          bryanthompson bryanthompson added a comment -

          Closed as duplicate of BLZG-38. Moved child tickets to BLZG-38.


            People

            • Assignee:
              bryanthompson bryanthompson
              Reporter:
              bryanthompson bryanthompson
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: