Uploaded image for project: 'Blazegraph (by SYSTAP)'
  1. Blazegraph (by SYSTAP)
  2. BLZG-1908

Update jackson.version from 2.2.3 to 2.4.4 for compatibility with Spark 1.6.1 Dataframe API

    Details

    • Type: New Feature
    • Status: Done
    • Priority: Medium
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: BLAZEGRAPH_2_2_0
    • Component/s: None
    • Labels:
      None

      Description

      The bigdata-cache module is used by DASL which ends up causing class conflicts in spark-DASL due to competing version of the Jackson JSON libraries brought about by a transient dependency on bigdata-core which uses Jackson 2.2.3. Spark SQL will only work with version 2.4.4, so this ticket is to upgrade the Jackson version in bigdata to 2.4.4.

        Activity

        Show
        beebs Brad Bebee added a comment - https://github.com/SYSTAP/bigdata/pull/393

          People

          • Assignee:
            jjcarbo Jim Carbonaro
            Reporter:
            jjcarbo Jim Carbonaro
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: