Uploaded image for project: 'Blazegraph (by SYSTAP)'
  1. Blazegraph (by SYSTAP)
  2. BLZG-1427

Recycling must be able to make progress while allocations contexts are open (interaction with session protection must not prevent recycling)

    Details

    • Type: Task
    • Status: Done
    • Priority: Medium
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: BLAZEGRAPH_RELEASE_1_5_3
    • Component/s: None
    • Labels:
      None

      Description

      Group commit currently creates an allocation context for an unisolated task. This context lives while the task is running and is released once it checkpoints. If the task checkpoints but the commit fails, then the entire write set is thrown away.

      The changes for BLZG-1235 and especially the support for an UNISOLATED connection object will also create allocation contexts which remain open while the connection is open. However, the problem is greatest with group commit since we can potentially have an unending stream of overlapping unisolated tasks such that allocation contexts are always active at each commit point. Under this scenario recycling would be deferred for as long as the workload exists.

        Issue Links

          Activity

          bryanthompson bryanthompson added a comment -

          Closed after review with Martyn. We always have a minReleaseAge of 1 millisecond. Therefore session protection is never activated. Therefore frees made within an allocation context are always logged as deferred frees (unless they are frees against slots that were never committed). Thus recycling always applies and this ticket may be closed.

          link RWStore behavior with allocation contexts


            People

            • Assignee:
              martyncutcher martyncutcher
              Reporter:
              bryanthompson bryanthompson
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: