Details

    • Type: Improvement
    • Status: Done
    • Priority: Medium
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: BLAZEGRAPH_2_1_0
    • Component/s: None
    • Labels:
      None

      Description

      The version of lucene that is used by bigdata is outdated. Current stable is Apache Lucene 5.x while bigdata uses outdated 3.x that often leads to dependency conflicts with libs that are using later lucene.

        Issue Links

          Activity

          bryanthompson bryanthompson added a comment -

          We will be pushing this feature out to 2.1.

          igorkim igorkim added a comment -

          Status of this task to date:

          • Lucene version was upgraded to 5.3.0
          • Core code and tests updated to be compatible with new Lucene version
          • Added rebuildTextIndex in REST API
          • Added controls to rebuild text index from Workbench
          • FTS enable made persistent in global row store (properties updated for 'namespace' and 'namespace.lex' records only).
          • Existing TestFullTextIndex.test_rebuildIndex extended to test actual rebuild of broken index (this test is failing due to no records actually made up to FTS index after rebuild).

          Remaining:

          • Fix root cause of failing TestFullTextIndex.test_rebuildIndex, Issue tracked to FTS index update, literals and blobs from triple store are parsed and tokenized properly by FullTextIndex.index, but after collected buffers flashed into newly created BigdataValueCentricFullTextIndex, it reports no records in there and does not bring any search results.
          beebs Brad Bebee added a comment -

          Code changes are merged down in https://github.com/SYSTAP/bigdata/pull/188.

          Hronom Eugene Tenkaev added a comment - - edited

          Here is my 50 cent, latest lucene release Apache Lucene 5.5.0, so that do not have lasted a little...

          beebs Brad Bebee added a comment -

          Created BLZG-1854 for Lucene 5.5.0.


            People

            • Assignee:
              igorkim igorkim
              Reporter:
              antonkulaga2 Anton Kulaga
            • Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: