Details

    • Type: Sub-task
    • Status: Done
    • Priority: Medium
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: BLAZEGRAPH_RELEASE_1_5_3
    • Component/s: RWStore
    • Labels:
      None

      Description

      The RWStore IAllocationContext interface is used to provide a scope around a group of alloc() and free() calls. This is currently used by GroupCommit, but there is a discussion of using this to prevent unisolated writes from being made after a call to RWStore.reset() by invalidating an IAssociationContext associated with the unisolated write.

      Currently the RWStore IAllocationContext interface is a marker interface. Instances of this marker interface are transparently established by establishAllocationContext() if they are used in alloc(), free(), or registerAllocationContext(). Establishing an IAllocationContext should be restricted to the explicit registerContext() method. This method is called by AbstractTask.IsolatedActionJournal<init>() as part of the GroupCommit support.

        Issue Links

          Activity

          bryanthompson bryanthompson added a comment -

          Fixed in a branch but still open against master.

          bryanthompson bryanthompson added a comment -

          This should be closed when BLZG-1407 is closed as the issue is addressed in that change set.


            People

            • Assignee:
              martyncutcher martyncutcher
              Reporter:
              bryanthompson bryanthompson
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 1 hour
                1h
                Remaining:
                Remaining Estimate - 1 hour
                1h
                Logged:
                Time Spent - Not Specified
                Not Specified