Uploaded image for project: 'Blazegraph (by SYSTAP)'
  1. Blazegraph (by SYSTAP)
  2. BLZG-1157

Disable the default namespace create (NSS/HA)

    Details

    • Type: Bug
    • Status: Closed - Won't Fix
    • Resolution: Cannot Reproduce
    • Affects Version/s: BIGDATA_RELEASE_1_5_0
    • Fix Version/s: None
    • Component/s: NanoSparqlServer
    • Labels:
      None

      Description

      The webapp startup logic in BigdataRDFServletContextListener automatically creates the Journal if it does exist and then automatically creates a default namespace named "kb". This ticket is to disable that behavior. Thus, on startup the Journal will be created but no namespace will be created.

      This ticket will break the following test suites:
      - HA
      - NSS
      - Blueprints (over the REST API)

      In addition it may cause integration problems with the javascript workbench and may require documentation changes for the blazegraph startup.

      Note that we already have an init parameter that can be specified in web.xml that determines whether or not this initial namespace creation takes place. See com.bigdata.rdf.sail.webapp.ConfigParams.CREATE. The default is currently true. This could be changed in web.xml.

        <context-param>
         <description>When true a new triple or quads store instance will be created
         if none is found at that namespace.</description>
         <param-name>create</param-name>
         <param-value>true</param-value>
        </context-param>
      

        Activity

        bryanthompson bryanthompson added a comment -

        Based on a code review, it looks like this is fully supported. The only issue is whether or not create:=true in web.xml as deployed.


          People

          • Assignee:
            bryanthompson bryanthompson
            Reporter:
            bryanthompson bryanthompson
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: