Uploaded image for project: 'Blazegraph (by SYSTAP)'
  1. Blazegraph (by SYSTAP)
  2. BLZG-1146

Literals with langs must be of rdf:langString datatype

    Details

    • Type: Bug
    • Status: Duplicate
    • Resolution: Duplicate
    • Affects Version/s: BIGDATA_RELEASE_1_4_0
    • Fix Version/s: None
    • Component/s: Bigdata RDF Database
    • Labels:
      None

      Description

      At the moment bigdata has "null" for literal with language as datatype, there is even no way to create langliteral with notnull datatype http://trac.bigdata.com/ticket/1094

      According to the SPARQL spec lang literals must be of rdf:langString datatype instead of null, see http://www.w3.org/TR/sparql11-query/

        Activity

        bryanthompson bryanthompson added a comment -

        Closing as duplicate of BLZG-1140. Both issues will be resolved by BLZG-1147 (openrdf 2.8)


          People

          • Assignee:
            Unassigned
            Reporter:
            antonkulaga antonkulaga
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: