Uploaded image for project: 'Blazegraph (by SYSTAP)'
  1. Blazegraph (by SYSTAP)
  2. BLZG-1122

Eclipse project in git repository is broken

    Details

    • Type: Bug
    • Status: Closed - Won't Fix
    • Resolution: Cannot Reproduce
    • Affects Version/s: trunk
    • Fix Version/s: None
    • Component/s: Other
    • Labels:

      Description

      The source version is 0b27fe2ea717e200be85fa8e145d5a7ea7215e6a comitted by Bryan Thompson <bryan@systap.com> 2014-11-20 01:40:25

      Diagnostics are:
      Project 'bigdata' is missing required source folder: 'bigdata-gom/src/resources'

      The folder is missed indeed.

      After the reference to the folder removed from Java Build Path, the project build successfully.

        Activity

        bryanthompson bryanthompson added a comment -

        This has been resolved in the current development branch.

        Workaround: edit the classpath and remove the empty directory.

        bryanthompson bryanthompson added a comment -

        Update: I just did a clean checkout from SF git and opened the project in eclipse. The project compiles without any modification.

        Was the problem reported with the ant build target or eclipse? I suspect that it was with the ant build....

        bryanthompson bryanthompson added a comment -

        I just verified that I can do "ant bundleJar" as well as "ant war" on the SF git checkout.

        Closed as "works for me".


          People

          • Assignee:
            martyncutcher martyncutcher
            Reporter:
            alexeikaigorodov alexeikaigorodov
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: