Uploaded image for project: 'Blazegraph (by SYSTAP)'
  1. Blazegraph (by SYSTAP)
  2. BLZG-1052

Property Path operator can become CPU bound

    Details

    • Type: New Feature
    • Status: Done
    • Priority: Highest
    • Resolution: Done
    • Affects Version/s: BIGDATA_RELEASE_1_3_1
    • Fix Version/s: None
    • Component/s: B+Tree
    • Labels:
      None

      Description

      The property path operation (ArbitraryLengthPathOp) can become CPU bound and non-responsive. It can also drive the heap heavily leading to high GC overhead. This occurs when the property path is fully materialized in cache for queries such as

        SELECT * {?s a* ?o}
      

      We need to review the code for sources of unnecessary heap pressure, refactor the code to derive two versions of the operator (one for the native heap and one for the JVM heap), and look at ways to relieve the CPU pressure, e.g., by yielding occasionally.

      Two other comments:


      - There may be cases (such as the above) where the GASService could provide an alternative execution strategy (however note that the GASService does not support the native heap at this time)
      - We are re-planning the sub-query at each invocation. It would be nice if we could avoid that overhead.

      Note: It is possible that the root cause is:

      • BLZG-1061 Property path operator should output solutions incrementally

        Issue Links

          Activity

          bryanthompson bryanthompson added a comment -

          This issue may have been resolved by BLZG-1061. We plan to conduct additional testing in future sprints focused on property path performance.

          bryanthompson bryanthompson added a comment -

          Closing as this ticket lacks a reproducer and several related issues were fixed.


            People

            • Assignee:
              michaelschmidt michaelschmidt
              Reporter:
              bryanthompson bryanthompson
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: