Uploaded image for project: 'Blazegraph (by SYSTAP)'
  1. Blazegraph (by SYSTAP)
  2. BLZG-1040

Object position of query hint is not a Literal.

    Details

    • Type: Bug
    • Status: Done
    • Resolution: Done
    • Affects Version/s: BIGDATA_RELEASE_1_3_1
    • Fix Version/s: None
    • Component/s: Other

      Description

      A client call died, and this was in the log ?. further log message to come

      base <https://temp-base-image-2-jjc.syapse.com/>
      prefix owl: <http://www.w3.org/2002/07/owl#>
      prefix based: <https://temp-base-image-2-jjc.syapse.com/bdm/api/appindividual/based:>
      prefix xsd: <http://www.w3.org/2001/XMLSchema#>
      prefix rdfs: <http://www.w3.org/2000/01/rdf-schema#>
      prefix dc: <http://purl.org/dc/elements/1.1/>
      prefix sys: <https://temp-base-image-2-jjc.syapse.com/bdm/api/kbobject/sys:>
      prefix kewd: <https://temp-base-image-2-jjc.syapse.com/bdm/api/appindividual/kewd:>
      prefix s: <https://temp-base-image-2-jjc.syapse.com/bdm/api/>
      prefix rdf: <http://www.w3.org/1999/02/22-rdf-syntax-ns#>
      prefix bds: <http://www.bigdata.com/rdf/search#>
      prefix kew: <https://temp-base-image-2-jjc.syapse.com/bdm/api/kbobject/kew:>
      prefix sysd: <https://temp-base-image-2-jjc.syapse.com/bdm/api/appindividual/sysd:>
      prefix base: <https://temp-base-image-2-jjc.syapse.com/bdm/api/kbobject/base:>
      prefix skos: <http://www.w3.org/2004/02/skos/core#>
      prefix syapse: <https://temp-base-image-2-jjc.syapse.com/graph/syapse#>
      SELECT ?x ?p ?o
      FROM <https://temp-base-image-2-jjc.syapse.com/graph/kew-group/abox>
      FROM <https://temp-base-image-2-jjc.syapse.com/graph/ontology/base>
      FROM <https://temp-base-image-2-jjc.syapse.com/graph/django/kew-group>
      FROM <https://temp-base-image-2-jjc.syapse.com/graph/syapse>
      FROM <https://temp-base-image-2-jjc.syapse.com/graph/ontology/kew>
      FROM <https://temp-base-image-2-jjc.syapse.com/graph/kew-group/vocabulary>
      FROM <https://temp-base-image-2-jjc.syapse.com/graph/ontology/sys>
      FROM NAMED <https://temp-base-image-2-jjc.syapse.com/graph/kew-group/abox>
      FROM NAMED <https://temp-base-image-2-jjc.syapse.com/graph/ontology/base>
      FROM NAMED <https://temp-base-image-2-jjc.syapse.com/graph/django/kew-group>
      FROM NAMED <https://temp-base-image-2-jjc.syapse.com/graph/syapse>
      FROM NAMED <https://temp-base-image-2-jjc.syapse.com/graph/ontology/kew>
      FROM NAMED <https://temp-base-image-2-jjc.syapse.com/graph/kew-group/vocabulary>
      FROM NAMED <https://temp-base-image-2-jjc.syapse.com/graph/ontology/sys>
      
      WHERE {
        hint:Query hint:queryId '371abffa-f677-11e3-812c-060f5cca0ee2' .
      
          { SELECT DISTINCT * {
          BIND (1 as ?workAroundForTrac943 )
          hint:SubQuery hint:runOnce true .
          { kewd:KbVariant_292356 sys:owner <https://temp-base-image-2-jjc.syapse.com/bdm/api/syuser/17>  }
          UNION
          { kewd:KbVariant_292356 sys:assignedProject / syapse:isPrivate false .
          }
          UNION
          { kewd:KbVariant_292356 sys:assignedProject / syapse:member <https://temp-base-image-2-jjc.syapse.com/bdm/api/syuser/17> .
          }
      } }
          kewd:KbVariant_292356 syapse:partlet ?x .
          ?x ?p ?o .
      
      }
      java.util.concurrent.ExecutionException: java.lang.Exception: java.lang.RuntimeException: Object position of query hint is not a Literal.
              at java.util.concurrent.FutureTask.report(FutureTask.java:122)
              at java.util.concurrent.FutureTask.get(FutureTask.java:188)
              at com.bigdata.rdf.sail.webapp.QueryServlet.doQuery(QueryServlet.java:625)
              at com.bigdata.rdf.sail.webapp.QueryServlet.doPost(QueryServlet.java:182)
              at com.bigdata.rdf.sail.webapp.RESTServlet.doPost(RESTServlet.java:237)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
              at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:738)
              at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:551)
              at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
              at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:568)
              at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:221)
              at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1111)
              at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:478)
              at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:183)
              at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1045)
              at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
              at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:199)
              at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:109)
              at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)
              at org.eclipse.jetty.server.Server.handle(Server.java:462)
              at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:279)
              at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:232)
              at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:534)
      
      

        Activity

        jeremycarroll jeremycarroll added a comment -
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: java.util.concurrent.ExecutionException: java.lang.Exception: java.lang.RuntimeException: Object position of query hint is not a Literal.
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at java.util.concurrent.FutureTask.report(FutureTask.java:122)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at java.util.concurrent.FutureTask.get(FutureTask.java:188)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.QueryServlet.doQuery(QueryServlet.java:625)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.QueryServlet.doPost(QueryServlet.java:182)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.RESTServlet.doPost(RESTServlet.java:237)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:738)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:551)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:568)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:221)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1111)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:478)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:183)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1045)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:199)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:109)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.Server.handle(Server.java:462)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:279)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:232)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:534)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:607)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:536)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at java.lang.Thread.run(Thread.java:745)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: Caused by: java.lang.Exception: java.lang.RuntimeException: Object position of query hint is not a Literal.
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.BigdataRDFContext$AbstractQueryTask.call(BigdataRDFContext.java:1161)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.BigdataRDFContext$AbstractQueryTask.call(BigdataRDFContext.java:492)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at java.util.concurrent.FutureTask.run(FutureTask.java:262)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011... 1 more
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: Caused by: java.lang.RuntimeException: Object position of query hint is not a Literal.
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTQueryHintOptimizer.getValue(ASTQueryHintOptimizer.java:606)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTQueryHintOptimizer.applyQueryHint(ASTQueryHintOptimizer.java:645)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTQueryHintOptimizer.processGroup(ASTQueryHintOptimizer.java:411)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTQueryHintOptimizer.processGroup(ASTQueryHintOptimizer.java:427)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTQueryHintOptimizer.processGroup(ASTQueryHintOptimizer.java:424)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTQueryHintOptimizer.optimize(ASTQueryHintOptimizer.java:149)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTOptimizerList.optimize(ASTOptimizerList.java:104)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.eval.AST2BOpUtility.convert(AST2BOpUtility.java:218)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.eval.ASTEvalHelper.evaluateTupleQuery(ASTEvalHelper.java:238)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.BigdataSailTupleQuery.evaluate(BigdataSailTupleQuery.java:93)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.BigdataSailTupleQuery.evaluate(BigdataSailTupleQuery.java:75)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.openrdf.repository.sail.SailTupleQuery.evaluate(SailTupleQuery.java:62)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.BigdataRDFContext$TupleQueryTask.doQuery(BigdataRDFContext.java:1280)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.BigdataRDFContext$AbstractQueryTask.call(BigdataRDFContext.java:1134)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011... 5 more
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: WARN : 9326356      qtp15337530-758 org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:592): /bigdata/sparql
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.Exception: java.lang.RuntimeException: Object position of query hint is not a Literal.
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.QueryServlet.doQuery(QueryServlet.java:633)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.QueryServlet.doPost(QueryServlet.java:182)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.RESTServlet.doPost(RESTServlet.java:237)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:738)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:551)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:568)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:221)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1111)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:478)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:183)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1045)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:199)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:109)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.Server.handle(Server.java:462)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:279)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:232)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:534)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:607)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:536)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at java.lang.Thread.run(Thread.java:745)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: Caused by: java.util.concurrent.ExecutionException: java.lang.Exception: java.lang.RuntimeException: Object position of query hint is not a Literal.
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at java.util.concurrent.FutureTask.report(FutureTask.java:122)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at java.util.concurrent.FutureTask.get(FutureTask.java:188)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.QueryServlet.doQuery(QueryServlet.java:625)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011... 24 more
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: Caused by: java.lang.Exception: java.lang.RuntimeException: Object position of query hint is not a Literal.
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: Caused by: java.lang.Exception: java.lang.RuntimeException: Object position of query hint is not a Literal.
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.BigdataRDFContext$AbstractQueryTask.call(BigdataRDFContext.java:1161)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.BigdataRDFContext$AbstractQueryTask.call(BigdataRDFContext.java:492)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at java.util.concurrent.FutureTask.run(FutureTask.java:262)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011... 1 more
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: Caused by: java.lang.RuntimeException: Object position of query hint is not a Literal.
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTQueryHintOptimizer.getValue(ASTQueryHintOptimizer.java:606)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTQueryHintOptimizer.applyQueryHint(ASTQueryHintOptimizer.java:645)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTQueryHintOptimizer.processGroup(ASTQueryHintOptimizer.java:411)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTQueryHintOptimizer.processGroup(ASTQueryHintOptimizer.java:427)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTQueryHintOptimizer.processGroup(ASTQueryHintOptimizer.java:424)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTQueryHintOptimizer.optimize(ASTQueryHintOptimizer.java:149)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTOptimizerList.optimize(ASTOptimizerList.java:104)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.eval.AST2BOpUtility.convert(AST2BOpUtility.java:218)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.eval.ASTEvalHelper.evaluateTupleQuery(ASTEvalHelper.java:238)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.BigdataSailTupleQuery.evaluate(BigdataSailTupleQuery.java:93)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.BigdataSailTupleQuery.evaluate(BigdataSailTupleQuery.java:75)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.openrdf.repository.sail.SailTupleQuery.evaluate(SailTupleQuery.java:62)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.BigdataRDFContext$TupleQueryTask.doQuery(BigdataRDFContext.java:1280)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.BigdataRDFContext$AbstractQueryTask.call(BigdataRDFContext.java:1134)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011... 5 more
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: WARN : 9326358      qtp15337530-758 org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:361): /bigdata/sparql
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.Exception: java.lang.RuntimeException: Object position of query hint is not a Literal.
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.QueryServlet.doQuery(QueryServlet.java:633)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.QueryServlet.doPost(QueryServlet.java:182)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.RESTServlet.doPost(RESTServlet.java:237)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:738)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:551)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:568)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:221)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1111)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:478)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:183)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1045)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:199)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:109)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.Server.handle(Server.java:462)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:279)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:232)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:534)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:607)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:536)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at java.lang.Thread.run(Thread.java:745)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: Caused by: java.util.concurrent.ExecutionException: java.lang.Exception: java.lang.RuntimeException: Object position of query hint is not a Literal.
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at java.util.concurrent.FutureTask.report(FutureTask.java:122)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at java.util.concurrent.FutureTask.get(FutureTask.java:188)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.QueryServlet.doQuery(QueryServlet.java:625)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011... 24 more
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: Caused by: java.lang.Exception: java.lang.RuntimeException: Object position of query hint is not a Literal.
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.BigdataRDFContext$AbstractQueryTask.call(BigdataRDFContext.java:1161)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.BigdataRDFContext$AbstractQueryTask.call(BigdataRDFContext.java:492)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at java.util.concurrent.FutureTask.run(FutureTask.java:262)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011... 1 more
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: Caused by: java.lang.RuntimeException: Object position of query hint is not a Literal.
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTQueryHintOptimizer.getValue(ASTQueryHintOptimizer.java:606)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTQueryHintOptimizer.applyQueryHint(ASTQueryHintOptimizer.java:645)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTQueryHintOptimizer.processGroup(ASTQueryHintOptimizer.java:411)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTQueryHintOptimizer.processGroup(ASTQueryHintOptimizer.java:427)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTQueryHintOptimizer.processGroup(ASTQueryHintOptimizer.java:424)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTQueryHintOptimizer.optimize(ASTQueryHintOptimizer.java:149)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.optimizers.ASTOptimizerList.optimize(ASTOptimizerList.java:104)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.eval.AST2BOpUtility.convert(AST2BOpUtility.java:218)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sparql.ast.eval.ASTEvalHelper.evaluateTupleQuery(ASTEvalHelper.java:238)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.BigdataSailTupleQuery.evaluate(BigdataSailTupleQuery.java:93)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.BigdataSailTupleQuery.evaluate(BigdataSailTupleQuery.java:75)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at org.openrdf.repository.sail.SailTupleQuery.evaluate(SailTupleQuery.java:62)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.BigdataRDFContext$TupleQueryTask.doQuery(BigdataRDFContext.java:1280)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011at com.bigdata.rdf.sail.webapp.BigdataRDFContext$AbstractQueryTask.call(BigdataRDFContext.java:1134)
        Jun 17 16:29:23 ip-10-16-0-50 bigdata: #011... 5 more
        
        
        jeremycarroll jeremycarroll added a comment -

        I was doing some stress testing as we prepare for our bigdata deployment
        - the particular test had four clients all running the same suite of queries, with mix of sparql update and sparql queries
        - since the suites were identical there was high convention. One of the clients died and this peculiar error message was in the log ? it is factually false

        bryanthompson bryanthompson added a comment -

        I will note that the AST data structures are not immutable. A side effect through sharing is not out of the question, as is a failure to publish a value due to a lack of synchronization across threads.

        The query plan operator data structures are immutable to eliminate the possibility of side effects or unpublished updates.

        jeremycarroll jeremycarroll added a comment -

        I have tried replicating with exactly the same code on both different AWS instances, and identical AWS instances. No matter what the recipe that was predictably failing (if rarely) yesterday is now working (on different hardware). My conclusion is that the problem was somehow hardware related.

        jeremycarroll jeremycarroll added a comment -

        I can now reliably reproduce this, in a Syapse specific test suite. It is fixed by the fix suggested in trac 983.

        bryanthompson bryanthompson added a comment -

        Fix for BLZG-1040 and BLZG-1043 (xsd:boolean data race).

        Committed revision r8685.


          People

          • Assignee:
            Unassigned
            Reporter:
            jeremycarroll jeremycarroll
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: