Details

    • Type: New Feature
    • Status: Done
    • Priority: Highest
    • Resolution: Done
    • Affects Version/s: BIGDATA_RELEASE_1_3_0
    • Fix Version/s: BLAZEGRAPH_2_1_0
    • Component/s: Bigdata SAIL
    • Labels:
      None

      Description

      It looks like we will get this for free by moving to Sesame 2.7.

      See https://github.com/jsonld-java/jsonld-java

        Issue Links

          Activity

          akuckartz Andreas Kuckartz added a comment -

          This seems to be a duplicate of BLZG-690

          akuckartz Andreas Kuckartz added a comment -

          This is not a bug, but an important feature request.

          beebs Brad Bebee added a comment -

          To receive JSON-LD results set the Accept: HEADER per below.

          curl -X POST http://localhost:9999/blazegraph/namespace/test/sparql --data-urlencode 'query=CONSTRUCT  WHERE { hint:Query hint:analytic "true" . hint:Query hint:constructDistinctSPO "false" . ?s ?p ?o }' -H 'Accept:  application/ld+json'
          

          To insert JSON-LD set the Content-Type HEADER per below.

          curl -X POST -H 'Content-Type:application/ld+json' --data-binary '@src/test/java/com/bigdata/rdf/rio/little.jsonld' http://localhost:9999/blazegraph/sparql
          
          nicholsn Nolan Nichols added a comment -

          Great, so blazegraph now supports json-ld? If so, great and thank you!

          Looks like https://github.com/SYSTAP/bigdata/pull/325 is private. Are the commits to https://github.com/SYSTAP/bigdata/ mirrored to https://github.com/blazegraph/database? Guessing not immediately anyways since the last commit is from 8 days ago.

          I rebuilt blazegraph using the master branch on https://github.com/blazegraph/database to check for json-ld support and not seeing it yet. Will this make its way into the open source code?


            People

            • Assignee:
              beebs Brad Bebee
              Reporter:
              mikepersonick mikepersonick
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: